Plug-in Development

This document describes how to set up an environment for developing plug-ins. It assumes you have
already read the introductory plug-in document that describes a plug-in’s internal directory structure.

. > bin
Environment =
Within your application directory, you will need to create a > ata
plugins directory, then subdirectories for each type of plug-in > ﬁ docs
you plan to develop, e.g. handlers, connectors, etc. I m lib
Each plug-in you develop will have its own subdirectory within the > m logs
folder of the associated plug-in type. For example: I m nbproject
~/plugins/connectors/HelloWorld/ v m plugins
~/plugins/connectors/FooBar/ @ build.xml

» [ connectors

Ant » [ handlers

G www

If you plan to use the Ant build script provided by Augur Systems
to build your plug-in (highly recommended!), then you need to
place it in the plugins directory.

To use the Ant script, you may need to install the ant command-line utility separately, if it is not already

on your machine. We recommend you use ant version 1.7 or later. You can get the latest version here:
http://ant.apache.org/

Alternatively, your Java editor may include a built-in implementation of Ant.

Skeleton

Contact Support to obtain a ZIP file containing a skeleton plug-in. It is a simplistic plug-in that just con-
tains a plug-in’s basic directory structure and a sort of “Hello World” source code implementation.

Alternatively, you might consider unzipping an existing plug-in as a template. Just be sure to first create a
new subdirectory at ~/plugins/<type>/<newPluginName> then copy the template’s * . api
file to that directory, and unzip it. Lastly, you’ll need to change the source code file name(s), and the
plug-in’s class name where it is referenced in
~/plugins/<type>/<newPluginName>/Plugin.properties.
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Building
The following describes how to compile and package a plug-in using the provided Ant script. If you do
not use this script, it is up to you to compile your plug-in code and to construct the plug-in * . api file.

Ant Script

When you develop a new plug-in you will need to add its name to the build script at
~/plugins/build.xml Follow the editing instructions embedded in that file.

Basically, you will just have to copy a line in the Ant target named build. In that line, you will edit your
plug-in’s name (the same as its folder name), and decide if you want to include your plug-in’s source code
in the * . api file (recommended default) or keep it private.

Building

During development, you just need to run the build target. From the command line, move into the
~/plugins directory, then execute: ant (Ant will automatically find the build.xml file in the cur-
rent directory because that is the default Ant script name. And, since build is configured to be the
default target, you do not need to specify the target name either.)

You can usually do the same thing from your IDE. The advantage of running at from within your IDE is
that you can usually click on any error message to focus your editor on the offending source code line.

If the build is successful, it will deposit a * . api file in the associated ~/plugins/ subdirectory, for
example: ~/plugins/connectors/HelloWorld. api

You can then install that plug-in in your application for testing:

» For Augur, install via the Configuration Editor.
« For Socket Station, just stop/start Socket Station.
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IDE Setup

An integrated development environment (IDE) helps you develop software faster and easier. An IDE
usually provides color-coded source editing, syntax-checking, code-completion, and other code develop-
ment features. You do not need to use an IDE to develop plug-ins (you could use a plain text editor in-
stead), but it is highly recommended!

To setup any IDE for developing your plug-in you will have to tell it three things:

1. Where are your Java source files located?
This should be the srec subdirectory within your plug-in’s development directory.

2. What is the Java classpath?

The classpath tells your IDE where to find 3rd-party Java classes that may be referenced by your
software. The classpath comprises directories, ZIP files, and/or JAR files. The classpath can include
your plug-in’s 1ib directory, if you need to include any libraries within your plug-in. However, the
minimal classpath must include the application’s core JAR files:

o For Augur:~/1ib/augur/*.jar
« For Socket Station: ~/1ib/ss/* . jar

3. What version of Java?

Currently, your plug-in’s Java code must target version 1.5 (also known as “Java 5” in marketing
terms). It is OK to develop with a newer version of Java (e.g. your IDE might run within Java 6).
However, you need to target version 1.5 during compilation. If you use the provided ant script,
then it will automatically take care of compiling your plug-in correctly. However, you still need to
configure the target in your IDE so that the IDE can best help you edit your software.

IDE Examples
The next section of this document describes the configuration for the NetBeans IDE. NetBeans is one
of many Java editors you can use to create plug-ins. The basic setup should be similar for other IDEs.
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NetBeans Setup

This section describes how to set up the NetBeans IDE to edit your plug-in code. You can download the
latest NetBeans from http://www.netbeans.org/ NetBeans bundles the IDE in several ways, depending on

what type of development you intend to do with it. For our plug-ins, you only need the “Java SE” bundle,
which is usually the smallest download.

Creating a New Project
You will only need to create a project once. From within that project, you can edit multiple plug-ins.

I. From the menu, select: File > New Project. A new window will pop up.

8.0.0
Steps Choose Project
1. Choose Project Categories: Projects:
2.  Java & Java Application
3 Maven & Java Desktop Application
] NetBeans Modules & Java Class Library
> ﬁ samples & Java Project with Existing Sources
~
Description:
Imports an existing Java application and its build script into an IDE e
project. In free-form projects, IDE commands use the Ant script that
( Help ) ( <Back ) M  Finish ) ( Cancel )
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2. Choose a Free-Form project.

Steps Name and Location

1. Choose Project Select the folder that contains the project's files and specify the location of t...
2. Name and Location

3. Build and Run Actions Location: /Users/cmjanicki/augur ( Browse... )
4. Source Package Folders

5. Java Sources Classpath Build Script: cvs /v300ct2008/augur/plugins /build.xml ( Browse... )
6. Project Output

Specify a name and location for the new project.

Project Name:  Augur Plug-ins

Project Folder: | /Users/cmjanicki/augur ( Browse... )

™ Set as Main Project

. The free-form project type uses your existing Ant script to run all

! project actions, such as Clean, Build, and Run. Changing the build
process requires editing the Ant build script manually. Consider using
the "Project with Existing Sources" project template for easier
long-term maintenance of your project.

( Help ) (<8ack) M / Finish (Cancel)

3. Set the following fields, then press the Next button:

Location:Augur’s home directory
« Build Script: ~/plugins/build.xml (within Augur’s home directory)

+ Project Name: Augur Plug-ins (or whatever)

Project Folder:Augur’s home directory
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4. Leave the defaults for the build script mapping, then press the Next button.

000 New Java Free-Form Project

Steps Build and Run Actions

1. Choose Project Mapping of General Project Actions to targets in custom build script
2. Name and Location
3. Build and Run Actions  Build Project: build
4. Source Package Folders
5
6

Java Sources Classpath Clean Project:
Project Output

Generate Javadoc:

Run Project:

W w

Test Project:

( Help ) ( <Back ) ENm—) Finish ( Cancel )

5. Leave the defaults blank for the Java source and test panels, then press the Finish button.

Creating a New Plug-in

For each plug-in, you will need to create the plug-in’s directory environment. Within NetBeans, this is as
easy as copying/pasting an existing plug-in directory structure. NetBeans will copy the entire directory.
You then need to rename a few files: I) the new directory name; 2) the name of your plug-in Java source
file(s), and 3) the name of your main class within the Plugin.properties file.

Alternatively, you could manually create the new directory, then unzip a template plug-in in that direc-
tory, and follow steps 2 and 3 above.

The following instructions tell NetBeans about the new src directory, and what NetBeans should use as
a classpath for evaluating the Java source files found there:

6. Open the projects window (or pop it into focus if it is already open) via the menu:
Window > Projects

7. Right-click on your project’s root node, then select Properties in the pop-up context menu. (A
new window will pop up to configure your project.)
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8.

On the left “Categories” panel of the Project Properties window, select the Java Sources cate-
gory. (This is where you tell NetBeans about the directories that may contain your java source files.
You may have more than one, if you are developing multiple plug-ins.)

e o Project Properties - Augur-v300ct2008
Categories:
o General Source Package Folders:
> Java Sources Becliyanld el - Add Folder...
o Java Sources Classpath augur/plug!ns/tonneaors/Telnet/sr_c Telnet/sr_c 0
> Output augur/plugins/connectors/ShellSession/src ShellSession/src .
5 3 augur/plugins/handlers/MathComparisonisMatch/src  MathComparisonlsMatch/src "
Build and Run augur/plugins/handlers /RSSOutputHandler/src RSSOutputHandler/src E]
©  Formatting Move Up
Test Package Folders:
Package Folder Label Add Folder...
Remove
Move Up
Source Level: ( JDK 1.5 H" ( Includes/Excludes... 3
Encoding: [UTF-8 Q

Any settings modified on this panel are for IDE purpose only and do not change the build script. If you
[ ! \, want to make changes in build process, please modify your build script manually.

( Help ) (Can:el 3 f—on—)

Press the Add Folder... button. A file browser will appear.

. Select the src folder for your plug-in. (Make sure the folder is highlighted. If you double-click it will

open the folder instead.) Press the Open button to confirm.

. Optional: Double-click in the Label column in the table, then shorten the label. We recommend

deleting everything before the plug-in name.

. On the left “Categories” panel of the Project Properties window, select the Java Sources Class-

path category. (This is where you tell NetBeans about classpath to be associated with each src
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directory you specified in the previous steps.)

Categories:

o General This classpath is used by the IDE features like code completion and refactoring while editing

o Java Sources the Java sources. These settings do not modify the build script.

z nga Sources Classpath ™ Separate Classpath for Each Source Package Folder

g utput

© Build and Run Source Package Folder: [ ShellSession/src [augur/plugins /connectors/ShellSession/src] H

© Formatti

ormating ava Sources Classpath:
augur/lib faugur/asi.jar Add JAR/Folder...
augur/lib faugur/augur.jar
augur/lib /augur/config.jar ( Remove )
augur/lib /augur/leasing.jar
augur/lib /augur/stubs.jar ( Move Up \
augur/lib/augur/dialogger.jar L.
Move Down

The Java platform is used by code completion and similar features and is also used for running
the Ant script from the IDE.

Java Platform: [JDK 1.5 (Default) m ( Manage Java Platforms... )

Any settings modified on this panel are for IDE purpose only and do not change the
£ e\ build script. If you want to make changes in build process, please modify your build
script manually.

( Help ) (Cancel) (—0K—9
T —

I3. Select the Separate Classpath for Each Source Package Folder option. This tells Net-
Beans to use a different classpath depending on which src directory your working in. Each plug-in
may need different resources, (e.g. from it’s own 1ib directory) so it is best to define a separate
classpath for each plug-in when using NetBeans.

4. From Source Package Folder drop-down list, select your plug-in’s source folder (the one you
set on the previous screen).
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I5. Press the Add JAR/Folder... button. A file browser will appear.

©®~"6  BowseJARorFolder
[ £ augur H-‘

Date Modified

Reference as

® Relative Path: B asijar Friday, June
B augur.jar Friday, June
augur/lib/augur/asi.jar, B config.jar Friday, June

O Absolute Path: B dialogger.jar Friday, June

/Users /cmjanicki/cvs /v B leasing.jar Friday, June
B stubs.jar Friday, June

File Format: | Classpath Entry (folder, ZI... m

( Cancel ) E—Ghmv—a
T ———

I6. Navigate to Augur’s ~/1ib/augur/ directory, then select all the JAR files in there. If your plug-in
has its own JARs (in it's own lib directory), add those too.

I7. Press the OK button. In the background, NetBeans will start processing your new classpath and
source settings, so the error messages related to unknown classes should start disappearing in the
editor.

Running the Ant Script

From within NetBeans, select the build. xml file from either the Files window (Window > Files) or
Projects window (Window > Projects). Then, from the Navigator window (Window > Naviga-
tor), you can right-click on the build target and select Run Target from the pop-up context menu.
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build.xml [Augur Plug-ins) - Navigator

Ant Targets

build
build:connectors
build:handlers

o

A2 A a4 N7

-build:plugin:jar+src
-build:plugin:jar-src
-build:plugin:javac
-build:plugin+src
-build:plugin-src

The build output will appear in a new panel. If there were errors, you can click on any underlined error
message to open the IDE to the associated line of your source code.

Also note that following any code errors, you will also see error lines showing the last location of the
build script. You can usually ignore these lines.

o TITeSTT UIr= PIuyInST Y IPIUYInITPTT Ty IPI Uy I nName T I I
79 <include name="**/* jar"/> [
80 </fileset> )
81 <fileset dir="1lib"> —
82| <j " xx ) /> : ‘Z
} Al
Output - Augur Plug-ins (build:one) o0

w build:one:
mmmmssss=ss== Build One Plug-in ==sss===m===
============= Build Plug-in: handlers/RSSOutputHandler =========z=z==
Qg Deleting directory /Users/cmjanicki/cvs/v30oct2008/augur/plugins/handlers/RSSOutputHandler/classes
Created dir: /Users/cmjanicki/cvs/v30oct2008/augur/plugins/handlers/RSSOutputHandler/classes
pluginClass = RSSOutputHandler.java ==sssssss===
Compiling 1 source file to /Users/cmjanicki/cvs/v30oct2008/augur/plugins/handlers/RSSOutputHandler/classes
Users/cmjanicki/cvs/v30oct2008/augur/plugins/handlers/RSSOutputHandler/src/RSSOutputHandler.java:30: cannot find symbc
symbol : class PropertiesParserz
location: package iai.util
iai.util.PropertiesParserz pp = getPluginInstanceWrapper().getProperties();
Note: /Users/cmjanicki/cvs/v30oct2008/augur/plugins/handlers/RSSOutputHandler/src/RSSFeed.java uses unchecked or unsafe
Note: Recompile with -Xlint:unchecked for details.
1 error

ins/build.xml:31: The followin
ins/build.xml:57: The followin

BUILD FAILED (total time: 1 second)

If all goes well, the build output will end with “BUILD SUCCESSFUL”.
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Output - Augur Plug-ins (build:one) o0

uD build:one:
4 == ======= Build One Plug-in ====s========

== Build Plug-in: handlers/RSSOutputHandler ========z=z===
23 Deleting directory /Users/cmjanicki/cvs/v30oct2008/augur/plugins/handlers/RSSOutputHandler/classes
Created dir: /Users/cmjanicki/cvs/v30oct2008/augur/plugins/handlers/RSSOutputHandler/classes
pluginClass = RSSOutputHandler.java ====s=sz=z===
Compiling 1 source file to /Users/cmjanicki/cvs/v30oct2008/augur/plugins/handlers/RSSOutputHandler/classes
Note: /Users/cmjanicki/cvs/v30oct2008/augur/plugins/handlers/RSSOutputHandler/src/RSSFeed.java uses unchecked or unsafe
Note: Recompile with -Xlint:unchecked for details.
Updated version date at /Users/cmjanicki/cvs/v30oct2008/augur/plugins/handlers/RSSOutputHandler/versions/1.0.01.propert
Building jar: /Users/cmjanicki/cvs/v30oct2008/augur/plugins/handlers/RSSOutputHandler.api
BUILD SUCCESSFUL (total time: 0 seconds)

Notes

If you change or update any of the ZIP/JAR files in your plug-in’s classpath, NetBeans may not notice.
However, you will notice if the editor warns of code errors that you know should be fine, per your latest
libraries. If this happens, you just have to stop/start NetBeans.
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